- 07 Feb 2024
- 2 Minutter å lese
- Skriv ut
- MørkLys
- Pdf
Enkel feilsøking for Vipps
- Oppdatert 07 Feb 2024
- 2 Minutter å lese
- Skriv ut
- MørkLys
- Pdf
Her er noen av de mest normale feilmeldinger man kan få mot Vipps
Nedenfor ser du løsninger på de forskjellige feilmeldingene som kan oppstå ved behandling av en ordre som er betalt via Vipps.
Link til Vipps portalen
Vipps Ingen Ordre
Når en kunde betaler med Vipps, blir betalingen først gjennomført. Når betalingen er bekreftet, sender Vipps en melding til nettbutikken for å informere om at betalingen er gjennomført, og deretter opprettes ordren.
Hvis vi ikke mottar en melding fra Vipps om at betalingen er gjennomført, blir det ikke opprettet noen ordre. Selv om dette ikke skjer ofte, kan det forekomme. I våre systemer ser vi at vi ikke har mottatt noen melding fra Vipps. I slike tilfeller vil kunden aldri se "ordrebekreftelsen", og de vil heller ikke motta en e-post med ordrebekreftelse. I tillegg blir det ikke opprettet en ordre i nettbutikken din.
Hvis du ikke gjør noe med dette, vil kunden få pengene tilbake etter 8 dager fordi ordren aldri er merket som sendt.
Vi har opprettet et verktøy i kontrollpanelet ditt som lar deg aktivere eller kansellere slike ordre.
Les mer om verktøyet.
I Vipps-portalen din kan du finne ordre-IDen som du trenger for å aktivere eller kansellere ordren. Hvis du vet hvilke produkter kunden har kjøpt, kan du aktivere ordren og deretter opprette en manuell ordre for å få dette registrert i regnskapet ditt.
Feilmelding: Client Error Response 404
[status code] 404
[reason phrase] Not Found
[url] https://api.vipps.no/Ecomm/v2/payments/T-1638377488-61a7a810ac2b0/capture
Årsak
Denne feilmeldingen skyldes kommunikasjonssvikt på APIet i den perioden som hindrer aktivering av betaling på ordren. Mest sannsynlig ligger betalingen som reservert i Vipps portalen.
Løsning
Logg inn i Vipps portalen for å se om transaksjonen er gått igjennom.
Om transaksjonen ikke er gått igjennom i Vipps portalen så kan dere prøve å endre status tilbake til sendt og aktivere betalingen på nytt.
Om det ikke lykkes så kan dere behandle ordren til tross for feilmeldinger og deretter aktivere transaksjonen manuelt i Vipps portalen.
Om transaksjonen er gått igjennom på Vipps portalen så kan ordren behandles til tross for feilmeldinger.
Om dere får feilmeldingen ofte kan det f.eks hjelpe med nye API nøkler. Sjekk artikkel for guide på hvordan du gjør dette enkelt her.
Feilmelding: Client Error Response 499
Vi klarte ikke å markere ordren som sendt med Vipps. Feilmelding: Client error response [status code] 499 [reason phrase]
[url] https://api.vipps.no/Ecomm/v2/payments/T-1695984355-6516aae3b87cd/capture
Årsak
Denne feilmeldingen skyldes kommunikasjonssvikt på APIet i den perioden som hindrer aktivering av betaling på ordren. Mest sannsynlig ligger betalingen som reservert i Vipps portalen.
Løsning
Logg inn i Vipps portalen for å se om transaksjonen er gått igjennom.
Om transaksjonen ikke er gått igjennom i Vipps portalen så kan dere prøve å endre status tilbake til sendt og aktivere betalingen på nytt.
Om det ikke lykkes så kan dere behandle ordren til tross for feilmeldinger og deretter aktivere transaksjonen manuelt i Vipps portalen.
Om transaksjonen er gått igjennom på Vipps portalen så kan ordren behandles til tross for feilmeldinger.